< Back to Support Home

Q: Can I batch process many photos at once in LUCiD?

A:

Yes – you can!

The easiest way to batch correct a large number of photos is:

  1. Open all the photos you want to correct in LUCiD.  You can drag a folder of images into LUCiD, or you can click File -> Open and select the photos you want to correct.
  2. Then, select one photo to start working on.  Use the navigation buttons at the top left to switch photos.
  3. With that photo visible, pick a preset to start working with, then adjust those settings if you want to.
  4. Once you love the look of this photo, copy these settings and paste them to all open photos.  Copy the settings with Edit -> Copy Setting, or CMD+C or CTRL+C.  Paste these settings to all photos with Edit->Paste Settings to all photos, or SHIFT+CMD+V or SHIFT+CTRL+V
Tweet about this on TwitterShare on FacebookGoogle+Pin on PinterestShare on LinkedInEmail to someone

Do you have more questions?

Our 24/7 support team is ready to help.